Cloudflare Availability Issues
Incident Report for Roadster
Postmortem

Cloudflare provided a post mortem on their blog. See below for details.

https://blog.cloudflare.com/cloudflare-outage-on-july-17-2020/

Posted Jul 27, 2020 - 16:56 UTC

Resolved
Cloudflare, a service we use for DNS services and caching is experiencing an outage that is impacting all Roadster services. The Cloudflare team is investigating.
Posted Jul 17, 2020 - 21:30 UTC