Persisting Express Storefront Performance Issues
Incident Report for CDK Modern Retail
Resolved
We have resolved the performance issue affecting Express Storefronts.
Posted Oct 29, 2020 - 17:34 CDT
Monitoring
Performance has returned to normal and we continue to monitor the situation to ensure it remains stable.
Posted Oct 29, 2020 - 14:55 CDT
Investigating
We are currently investigating intermittent issues causing some users to receive error messages when trying to access Express Storefronts.
Posted Oct 29, 2020 - 14:26 CDT
This incident affected: Americas Datacenter (Express Storefront).